Kapitel 15. Menyer

Innehållsförteckning

1. Introduktion till menyer
1.1. Sammanhangsmenyer
1.2. Tear-off menus
1.3. Tab menus
2. The ”File” Menu
2.1. Overview
2.2. New
2.3. Create
2.4. Open
2.5. Open as Layers
2.6. Open Location
2.7. Open Recent
2.8. Spara
2.9. Save as
2.10. Save a Copy
2.11. Save as Template
2.12. Revert
2.13. Print
2.14. Stäng
2.15. Close all
2.16. Quit
3. The ”Edit” Menu
3.1. ”Edit” Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into
3.11. Paste as
3.12. Buffer
3.13. Töm
3.14. Fill with FG Color
3.15. Fill with BG Color
3.16. Fill with Pattern
3.17. Stroke Selection
3.18. Stroke Path
3.19. The ”Preferences” Command
3.20. Keyboard Shortcuts
3.21. Modules
3.22. Units
4. The ”Select” Menu
4.1. Introduction to the ”Select” Menu
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Distort
4.15. Rounded Rectangle
4.16. Toggle QuickMask
4.17. Save to Channel
4.18. To Path
5. The ”View” Menu
5.1. Introduction to the ”View” Menu
5.2. Ny vy
5.3. Punkt för punkt
5.4. Zooma
5.5. Shrink Wrap
5.6. Helskärm
5.7. Navigeringsfönster
5.8. Display Filters
5.9. Visa markering
5.10. Show Layer Boundary
5.11. Visa hjälplinjer
5.12. Visa rutnät
5.13. Visa samplingspunkter
5.14. Fäst mot hjälplinjer
5.15. Fäst mot rutnät
5.16. Snap to Canvas
5.17. Snap to Active Path
5.18. Padding Color
5.19. Visa menyrad
5.20. Visa linjaler
5.21. Visa rullningslister
5.22. Visa statusrad
6. The ”Image” Menu
6.1. Översikt
6.2. Duplicate
6.3. Läge
6.4. RGB-läge
6.5. Grayscale mode
6.6. Indexed mode
6.7. Transformera
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Guillotine
6.11. Canvas Size
6.12. Fit Canvas to Layers
6.13. Fit Canvas to Selection
6.14. Print Size
6.15. Skala bild
6.16. Beskär till markering
6.17. Autocrop Image
6.18. Zealous Crop
6.19. Sammanfoga synliga lager
6.20. Flatten Image
6.21. Align Visible Layers
6.22. Hjälplinjer
6.23. Ny hjälplinje
6.24. New Guide (by Percent)
6.25. New Guides from Selection
6.26. Ta bort alla hjälplinjer
6.27. Configure Grid
6.28. Bildegenskaper
7. The ”Layer” Menu
7.1. Introduction to the ”Layer” Menu
7.2. Nytt lager
7.3. New From Visible
7.4. Duplicate layer
7.5. Förankra lager
7.6. Merge Down
7.7. Delete Layer
7.8. The Text Commands of the Layer Menu
7.9. Förkasta textinformation
7.10. ”Stack” Submenu
7.11. Select Previous Layer
7.12. Välj nästa lager
7.13. Select Top Layer
7.14. Select Bottom Layer
7.15. Höj lager
7.16. Lower Layer
7.17. Layer to Top
7.18. Layer to Bottom
7.19. The ”Reverse Layer Order” command
7.20. The ”Mask” Submenu
7.21. Lägg till lagermask
7.22. Tillämpa lagermask
7.23. Ta bort lagermask
7.24. Visa lagermask
7.25. Redigera lagermask
7.26. Inaktivera lagermask
7.27. Mask till markering
7.28. Add Layer Mask to Selection
7.29. Subtract Layer Mask from Selection
7.30. Intersect Layer Mask with Selection
7.31. The ”Transparency” Submenu of the ”Layer” menu
7.32. Lägg till alfakanal
7.33. Ta bort alfakanal
7.34. Färg till alfa
7.35. Semi-flatten
7.36. Threshold Alpha
7.37. Alpha to Selection
7.38. Add Alpha channel to Selection
7.39. Subtract from Selection
7.40. Intersect Alpha channel with Selection
7.41. The ”Transform” Submenu
7.42. Flip Horizontally
7.43. Flip Vertically
7.44. Rotate 90° clockwise
7.45. Rotate 90° counter-clockwise
7.46. Rotate 180°
7.47. Arbitrary Rotation
7.48. Offset
7.49. Layer Boundary Size
7.50. Layer to Image Size
7.51. Scale Layer
7.52. Beskär till markering
7.53. Autocrop Layer
8. The ”Colors” Menu
8.1. Introduction to the ”Colors” Menu
8.2. Colors Tools
8.3. Invert
8.4. Value Invert
8.5. Use GEGL
8.6. The ”Auto” Submenu
8.7. Equalize
8.8. Vitbalans
8.9. Color Enhance
8.10. Normalisera
8.11. Stretch Contrast
8.12. Stretch HSV
8.13. The ”Components” Submenu
8.14. Channel Mixer
8.15. Compose
8.16. Decompose
8.17. Recompose
8.18. The ”Map” Submenu
8.19. Rearrange Colormap
8.20. Set Colormap
8.21. Alien Map
8.22. Color Exchange
8.23. Gradient Map
8.24. Palette Map
8.25. Rotate Colors
8.26. Sample Colorize
8.27. The ”Info” Submenu
8.28. Histogram
8.29. Border Average
8.30. Colorcube Analysis
8.31. Smooth Palette
8.32. The Color Filters
8.33. Colorify
8.34. Färg till alfa
8.35. Filter Pack
8.36. Hot
8.37. Max RGB
8.38. Retinex
9. The ”Tools” Menu
9.1. Introduction to the ”Tools” Menu
10. The ”Filters” Menu
10.1. Introduction to the ”Filters” Menu
10.2. Repeat Last
10.3. Re-show Last
10.4. Reset All Filters
10.5. The ”Python-Fu” Submenu
10.6. Undermenyn ”Script-Fu”
11. The ”Windows” Menu
11.1. ”Windows” Menu Entries
11.2. The ”Recently Closed Docks” submenu
11.3. The ”Dockable Dialogs” submenu
12. ”Hjälp”-menyn
12.1. Introduktion till ”Hjälp”-menyn
12.2. Hjälp
12.3. Sammanhangshjälp
12.4. Dagens tips
12.5. Om
12.6. Insticksbläddrare
12.7. Procedurbläddrare
12.8. GIMP på nätet

1. Introduktion till menyer

There are many places in GIMP where you can find menus. The aim of this chapter is to explain all the commands that are accessible from the image menu bar and the image menu you can get by right clicking in the canvas. All the context menus and the menu entries for the other dialogs are described elsewhere in the chapters that describe the dialogs themselves.

1.1. Sammanhangsmenyer

If you right-click on certain parts of the GIMP interface, a ”context menu” opens, which leads to a variety of functions. Some places where you can access context menus are:

  • Clicking on an image window displays the Image menu. This is useful when you are working in full-screen mode, without a menubar.

  • Clicking on a layer in the Layers Dialog or on a channel in the Channels Dialog displays functions for the selected layer or channel.

  • Right-clicking on the image menubar has the same effect as left-clicking.

  • Right-clicking on the title bar displays functions which do not belong to GIMP, but to the window manager program on your computer.

1.2. Tear-off menus

There is an interesting property associated with some of the menus in GIMP. These are any of the menus from the Image context menu you get by right-clicking on the canvas and any of its submenus. (You can tell that a menu item leads to a submenu because there is an icon next to it.) When you bring up any of these menus, there is a dotted line at the top of it (tear-off line). By clicking on this dotted line, you detach the menu under it and it becomes a separate window.

Figur 15.1. The ”windows” submenu and its tear-off submenu

The windows submenu and its tear-off submenu
The windows submenu and its tear-off submenu

Tear-off menus are actually independent. They are always visible, their functions always apply to the current image, and they persist when all of the images are closed. You can close a tear-off submenu by clicking on the dotted line again or closing the window from the window manager on your computer (often by clicking on an X icon in the upper right corner of the window).

1.3. Tab menus

The following type of menus is not related to the image menu bar, but for the sake of completeness:

Every dockable dialog contains a Tab Menu button, as highlighted below. Pressing this Tab Menu button opens a special menu of tab-related operations, with an entry at the top that opens into the dialog's context menu.

Figur 15.2. A dockable dialog.

A dockable dialog.

A dialog window with the Tab menu button highlighted.

A dockable dialog.

The Tab menu.


See Avsnitt 2.3.5, ”Flikmeny” to learn more about Tab menus.